OVHCloud Customer Services Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
us.ovh.com
Incident Report for Customer Service
Resolved
Due to Load balancers work in progress, us.ovh.com website is unavailable. We're currently working on it.

Update(s):

Date: 2021-10-05 13:53:25 UTC
us.ovh.com is now available
Posted Oct 05, 2021 - 13:39 UTC
This incident affected: Corporate websites || Corporate websites.