Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2026 - 08:30 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled on our Control Panel for CA and EU regions.
Start time : 16/09/2026 08:30 UTC End time : 16/09/2026 10:30 UTC Service impact : During the maintenance, customers may experience latency or caching issue on the Control Panel. Service improvement : As part of our continuous improvement policy, we will be performing a major update to the beta version of the Control panel. We advise customers who encounter any display issues, to clear their browser cache.
Thank you for your understanding.
Posted Sep 16, 2026 - 08:23 UTC
This scheduled maintenance affects: Control panel & API || Control panel (CA, EU).