OVHCloud Customer Services Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
FS#12080 — Bank Card Payment
Incident Report for Customer Service
Resolved
The page for the bank card payment is not accessible anymore. we are investigating.

Update(s):

Date: 2014-11-22 11:10:07 UTC
We corrected the problem, the payment page is available again.
Posted Nov 22, 2014 - 11:09 UTC