OVHcloud Customer Services Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
[CA][Customer Service] - Services renew incident notification
Incident Report for Customer Service
Resolved
Start time : 18/07/2024 14:00 UTC
End time : 19/07/2024 09:05 UTC
Our technical teams resolved the issue. All impacted services are now operational.
Posted Jul 19, 2024 - 09:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2024 - 20:56 UTC
Investigating
Start time : 18/07/2024 14:00 UTC
Service impact : Customers aren't able to renew their services by credit card.
Workaround : Customers can use other payment methods to renew their services.
Ongoing actions : Investigating
Our technical teams are working on the issue.
Update will be posted as significant progress is made.
Posted Jul 18, 2024 - 20:33 UTC
This incident affected: Corporate websites || Corporate websites.