OVHCloud Customer Services Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
PayPal issue
Incident Report for Customer Service
Resolved
PayPal is currently experiencing disruptions affecting some transactions.

We will inform you as soon as everything is back to normal.

Update(s):

Date: 2021-10-05 13:00:27 UTC
The incident is finished.
Posted Oct 05, 2021 - 07:56 UTC
This incident affected: Corporate websites || Corporate websites.