We would like to inform you that the incident on our Support offer has now been resolved.
Here is detail for this incident : Start time : 28/04/2025 10:25 UTC End time : 30/04/2025 07:28 UTC
We thank you for your understanding and patience throughout this incident.
Posted Apr 30, 2025 - 14:59 UTC
Identified
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : The situation is much improved, but we're still working on the active workaround to avoid any inconvenience to the support.
We will keep you informed of any further developments. We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 29, 2025 - 09:30 UTC
Update
We are currently impacted by the Regional Power Outage affecting Spain & Portugal. Incident Details :
Start time : 28/04/2025 10:25 UTC Impacted Service(s) : Support in Spain and Portugal is unreachable. Support services in Local language are unavailable, calls and chats are being diverted to English speaking personnel. Customers Impact : Customers cannot contact the local Support. You may experience delays when trying to contact our teams Based in Spain or Portugal Root Cause : This incident is caused by electrical issue in Spain. Workaround : Calls are redirected to an English-speaking call center
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 28, 2025 - 12:41 UTC
Investigating
We are currently experiencing an extern event affecting our Support offer. Start time : 28/04/2025 10:25 UTC
Our teams are fully committed to investigating this issue and working towards a resolution as soon as possible. As investigations are ongoing, we will share any new findings or updates with you as soon as possible.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 28, 2025 - 12:28 UTC
This incident affected: Support || Southern Europe (ES, PT).