OVHCloud Customer Services Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
FS#12533 — Credit card payment
Incident Report for Customer Service
Resolved
The payment by credit card page is currently unavailable. We will intervene.

Update(s):

Date: 2015-02-02 19:03:17 UTC
The service is available again.
Posted Feb 02, 2015 - 19:01 UTC