OVHCloud Customer Services Status

Current status
Legend
  • Operational
  • Degraded performance
  • Partial Outage
  • Major Outage
  • Under maintenance
FS#12938 — Bank card payments
Incident Report for Customer Service
Resolved
The secure bank card payment system is currently unreachable. We will investigate.

Update(s):

Date: 2015-03-30 17:49:16 UTC
Service is available again.
Posted Mar 30, 2015 - 11:55 UTC